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Instructions for installing the files on this CD assuming that
the introECD installer did not work.
This README file is specifically for the CD that accompanies the text, the original
README file that accompanies the MicroSim installation disk is included at the end of
these notes. Please read and follow these instructions carefully or you will not be able to
make use of the example files included on this CD.
Be sure that you have administrator privileges on the machine you are installing this
software on.
This CDROM contains the following (you must install these items in the order
listed):
1

The installer for the MicroSim evaluation version of DesignLab release 8. You
should install this program using the default directory suggested by the installer
(on your C drive). If you install it anywhere else, the library links in the enclosed
PSPICE files will be incorrect and you will have to change them in each
individual schematic file before the files will run. To install this program doubleclick on SETUP.EXE and follow the directions given. Notes: 1) Be very patient
when the installer updates your registry information (near the end of the install) it may take a couple of minutes and if you restart during this time you can
corrupt your registry, which may require you to reinstall your operating system.
2) Do NOT install the Adobe Acrobat Reader program included with this program
- it is an old version and may cause you problems. If you need a copy of Acrobat,
you can download one for free from http://www.adobe.com/products/acrobat/.

2

A folder called IntroECD. This folder contains all of the PSPICE simulation files,
Mathematica notebooks, Matlab scripts, and Excel spreadsheets for the examples
and exercises in the book. You should put this folder at the top level on your C
drive (i.e., do not put it in another folder). The PSPICE files are further
organized into folders for each chapter. There are pdf files that describe the
simulation files available. If you do not put this folder at the top level on your C
drive, the library links in PSPICE will be incorrect and you will have to change
them in each individual schematic file before the files will run.
NOTE: After moving this folder over to your hard drive, you must change the
"read only" attribute of all of the folders and files. To do so, right-click on the
IntroECD folder and select "properties". Go to the "general" tab and uncheck the
"Read Only" attribute and click "Apply." A dialog box should open asking if you

want to make this change in just this folder, or this folder and all subfolders and
files as well; select all subfolders and files and click "OK." If this dialog box does
not appear, you may have to go into the subfolders one at a time, select all files
(Ctrl-A) and change the attribute (you can do this for all of the files in each folder
at one time, so it won't take too long). Depending on your operating system and
settings, the IntroECD folder and the other folders within it may not say they are
Read Only. In this case, you may need to go into each folder one at a time, select
all of the files and remove the Read Only attribute.
The IntroECD folder also contains all of the companion sections referred to in
the text along with Appendixes C and D. These are provided as pdf files.
3

A folder called Userlib containing the custom model libraries produced for this
text. After you have installed DesignLab, you should place the contents of this
folder in the folder “C:\MSimEv_8\UserLib”, which was put on your system by
the DesignLab installer script.

In addition to the material on this CD, you will need the MATLAB program if you want
to run the MATLAB scripts included here, a copy of the Mathematica program or the
Mathreader program if you want to look at the mathematica files, and Excel or a
compatible spreadsheet program if you want to run the spreadsheets. A student version of
MATLAB can probably be purchased from your university bookstore and the Mathreader
program can be downloaded for free from www.wolfram.com./products/mathreader/.
Also, prior to using PSPICE, you need to configure the MicroSim Schematics editor
to know about the model libraries used in the book. To do this, you first need to start the
program. If you have installed it correctly, you should be able to go to the Start menu, go
to “Programs” then to “DesignLab Eval 8” and then select “Schematics.” Once you have
started the program, go to the “Options” menu and select “Editor Configuration…”
The “Editor Configuration” dialog box will open and you will see a list of libraries and
some buttons. Click on the “Library Settings…” button. The “Library Settings” dialog
box is now displayed and has a list of device libraries shown. The student version of the
program limits you to ten libraries, so you must delete one of the existing libraries to
make room for the book libraries. In the library list, select “*BREAKOUT [.slb]” and
click on “Delete”. Next, click on “Browse…”. The “Browse” box should now open and
you should be in the directory “UserLib”. You should see two files; “Book.slb” and
“Book2.slb” (if you don't, be sure you performed step 3 in the installation procedure
above). Open “Book.slb” and you will be returned to the Library Settings dialog box with
“C:\MSimEv_8\UserLib\Book” showing up in the “Library Name:” box. Uncheck the
box labeled "Package" if it is checked. Click on the “Add*” button. Now click on
“Browse…” again, and open “Book2.slb”. Uncheck the "Package" box and click on the
“Add*” button again. You can now click on the “OK” button in the Library Settings
dialog box and then click on “OK” in the “Editor Configuration” dialog box. The
schematic editor should now be set up to function properly with the schematic files
included with the text. NOTE: You will see an error message from PSPICE Schematics

telling you that it can't find the files Book.plb and Book2.plb. You may safely ignore this
error message, you don't need these files.
Should you ever want to have the Breakout library of schematic symbols available again,
simply delete go back through this process but delete one of the other libraries and add
the Breakout library. The Breakout library contains basic symbols that you can then
customize. There are also other symbol libraries provided by Microsim that you can use.
They are all in the folder C:\MSimEv_8\lib.

To run the MicroSim installation program, double-click on
SETUP.EXE and follow the directions given.
The original MicroSim README file follows:

Release 8.0
This Read Me file contains last-minute information for all MicroSim programs. The information in
the manuals and Help that are provided with your programs also contain essential information to
help you begin using your MicroSim programs.
This Read Me file is divided into the following sections:
• Installation
• What's New with Your MicroSim Applications?
• General Information
• Tech Tips
• Documentation Errata

Installation
Installing Release 8


There is a limit to the length of file names (for example: C:\MicroSim\Evaluation\DLab\Release8 )
when installing MicroSim programs. If you install with a file name that exceeds the maximum
amount of characters allowed, towards the end of the installation, you will receive an error
message or the installation will be canceled. When installing MicroSim DesignLab, there is a limit
of 110 characters or less for the destination directory. When installing other MicroSim programs,
the character limit is 220 or less.
Installing Online Manuals


When you received your MicroSim programs, you also received online manuals with the Adobe
Acrobat Reader. For information about how to use the Adobe Acrobat Reader, refer to the Adobe
Acrobat Reader Online Guide provided with your MicroSim programs.
To start the reader

1
2
3
4

In Windows 95, point to the MicroSim Program group.
Point to Accessories.
Click Online Documentation to launch the Reader.
Click the appropriate manual.

To view the Adobe Acrobat Reader Online Guide
1 In Windows Explorer, move to the \<Acrobat Reader directory>\Help directory.
2 Double-click Acrobat.pdf.
Searching the online manuals
These manuals are supplied with an across-book index and search mechanism. Use the toolbar
buttons shown below to start a search and view the results, respectively:

For information about how to use the search feature, refer to the Adobe Acrobat Search Online
Guide contained in \<Acrobat Reader directory>\Help. (In Windows Explorer, double-click
search.pdf.)
Note: MicroSim recommends that you install the online manuals once, in a single location.
You do not need to install the online documentation for both the registered version and
the evaluation version.
Installing PCBoards


During installation of PCBoards, you are prompted for the sp.pas file. You must have the floppy in
the drive when installing this file. On some Windows 95 machines, if you press Browse without
the floppy in the drive, the installation will crash. Because Uninstall will not work after this type of
crash, re-install the software over the first installation attempt.

What's New with Your MicroSim Programs?
Refer to the manuals and Help provided with your programs for more information about what's
new for Release 8.

Schematics


If you are upgrading from a previous version (7.1 or earlier), review the following functionality
changes to Schematics.
Undo information is kept after a simulation is finished
Earlier Versions: Undo information was unavailable from the create Netlist or Simulate
commands.
Release 8.0: You can now undo after using these commands. (Your schematics are still
automatically saved to be consistent with the simulation results).
Connectivity Via Label netlisting option default setting
Earlier Versions: In version 6.3, there was only a global default. All designs were controlled by
the current setting. In version 7.1, Schematics stored this setting with the topmost design. Any
subschematics used the setting of the topmost design.

Release 8.0: Instead of being controlled by the topmost design's setting, the Connectivity Via
Label option (and the associated Append Page Number to wire labels option) within each
subschematic is used during netlisting. Subschematics created by someone else can be used
without having to know the original setting.
If you used Connectivity Via Label in hierarchical designs under version 7.1, do one of the
following:
• Update each subschematic to have this option set (from the Options menu, select Restricted
Operations).
Or
• Add the following option to the [SCHEMATICS] section of MSIM.INI:
NlTopSchConnViaWireLabel=ON
This option will cause netlisting to revert to using the setting from the topmost schematic.
Note: This affects ALL schematics.
Zoned Borders
When you open Schematics, the default border that displays is Zoned, but you can disable the
zoned borders and enable the single-line border (Outline) from previous versions of Schematics
by doing the following:
1 From the Options menu, select Editor Configuration, then click Page Settings.
2 Choose Outline for each page size that you want to display a single-line border.
Default font is Arial
Earlier Versions: The default font for Schematics was Modern.
Release 8.0: The default font is Arial. Also, the Display Preferences and Text Properties dialog
boxes support only TrueType fonts. If you use Modern or another non-TrueType font, you may
see text alignment differences in existing schematics due to differences in how Windows scales
the fonts.
You can go back to using Modern as your default font by adding the following item to the
[SCHEMATICS] section of MSIM.INI:
BASEFONTNAME=MODERN
This will change the default font from Arial to Modern.
Changing fonts for individual layers
Earlier Versions: The default font was changed by using Editor Configuration on the Options
menu.
Release 8.0: You can change fonts for individual layers by using Display Preferences on the
Options menu.
Enabling and disabling toolbars and status line
Earlier Versions: Display Options on the Options menu enabled and disabled the display of
toolbars and the status line.
Release 8.0: Enable Toolbars and Status Bar commands on the View menu.
Multiple toolbars
There are now multiple toolbars you can individually enable and disable in the Toolbars dialog
box. All simulation-related buttons are in their own toolbar.
Options/Display Preferences vs. Options/Set Display Level

Earlier Versions: Set Display Level on the Options menu globally enabled and disabled the
display of schematic items such as markers and title blocks.
Release 8.0: You can use Display Preferences on the Options menu to configure colors, fonts,
and line styles, as well as globally enable and disable the display of schematic items (layers).
Editing Graphics and Text Properties
In addition to changing the default settings of layers in Display Preferences, you can change
display properties for individual layers in the current design by doing the following:
1 Click to select the item.
2 From the Edit menu, select Graphics Properties, or select Text Properties.
You can also double-click the object to display the appropriate dialog box.
PRINTERLINEWIDTH option now obsolete
Earlier Versions: This item could be added to the MSIM.INI file to make wires and buses thicker
when printing.
Release 8.0: Display Preferences on the Options menu provides width control for both display
and printing.
Block/Graphics resizing
Earlier Versions: Blocks in the schematic editor and graphics in the symbol editor were resized
by holding down the <SHIFT> key and dragging with the right mouse button.
Release 8.0: You can resize blocks and graphics by using handles. Select a block or graphic to
display the handles and drag a handle to resize it to the appropriate size.
Automatic pin creation on hierarchical blocks
If you associate an existing schematic or XNF file with a block, pins corresponding to the
interface ports with the subschematic or XNF file are automatically created and placed on the
block.
Hierarchical schematics with multi-signal interface ports
Earlier Versions: Pin names on blocks and symbols had to match exactly the labels used on
underlying interface ports, and vice versa.
Release 8.0: Netlisting of hierarchical symbols and blocks has been extended to allow bus pins
to connect to individual signal ports.
The following scenarios can happen:
• A block with 1 pin A[0-2] and a subschematic can have 3 interface ports A0, A1, A2.
• A block with 3 pins B0, B1, B2 and a subschematic can have 1 interface port B[0-2].
Selecting items
In Release 8.0, selecting items includes the following functionality:
• To select all segments of a wire or bus, hold down the <ALT> key as you select a segment.
• To select an extended area, hold down the <SHIFT> key at the same time as selecting an
area.
• You cannot select a part and one of its attributes at the same time.
• When you select wire and bus attributes, in addition to the segment that owns it becoming
colored, a dotted line is drawn from the attribute back to the segment that owns it.
Part Browser - wildcard searching

Earlier Versions: To search for parts using wildcards in part names, previously you needed to
enter the pattern (e.g., 74*) and press <ENTER> to see the list of names.
Release 8.0: You do not need to press <ENTER>; as you type in the name, matching items are
displayed in the list automatically.
Edit/Convert Block & File/Symbolize
These menu commands have been changed to include the necessary path information, to ensure
that when the symbol created is used, the associated subschematic can be found.
Searching for subschematics and local symbol libraries
Earlier Versions: In versions 6.3 and earlier, subschematics and local symbol libraries were
previously searched for in the following order until found:
• the directory of the containing schematic
• along the library path
Release 8.0: Searching for subschematics was changed to the following:
• if referenced by a hierarchical block, the directory of the schematic containing the block
• if referenced by a hierarchical symbol, the directory of the symbol library containing the
symbol
This change was made so that subschematics that were associated with hierarchical symbols
could be put in the same directory as the symbol library and having subschematics with the same
name in other directories would not be inadvertently used.
Updating schematics from PLSyn
The defaults for the AUTOPLACEX and AUTOPLACEY .INI items that control placement when
updating the schematic from PLSyn have been changed from 100 and 150 to 200 and 200,
respectively. This may cause pages created by adding PLDs from PLSyn to have a slightly
different appearance.
NC symbol in Schematics
Earlier Versions: The NC symbol was removed from port.slb because it could
create disconnects within subcircuits that produced inaccurate simulation results.
Release 8.0: If you have schematics using this symbol, replace it with the new
NoConnect symbol (attaching it directly to the pin of the part) to indicate that the pin
is intentionally left unconnected. The old NC symbol is in obsolete.slb (the library that
contains symbols that is not being shipped with this release). If you still want to use
NC, you can configure obsolete.slb by using Editor Configuration on the Options
menu.
The obsolete.slb is located in the \MSim_8\lib directory.

General Information
Printing Online Manuals


When printing the online manuals, you can print the whole manual, the current page, or a range
of pages. If you are having difficulty printing the whole manual, there is a chance that your printer
doesn't have enough memory to sustain the size of the .pdf file. In this case, use the page range
printing option.

Schematics


Warnings are created for parts not included in the simulation
When creating a simulation netlist, Schematics now generates warnings
for parts that are not included in the simulation. Parts must have a
TEMPLATE attribute with a value to be included in the simulation. To suppress these
warnings for parts that are layout specific, such as connectors, you can add an
attribute MODEL=*IGNORE* to the symbol. We have done this for the symbols for
connectors in connect.slb.


The OrCAD Translator does not translate signal names with a backslash at the end of the signal
name correctly, e.g., OUT\ is not correctly translated.


Troubleshooting
If you get an "Unable to start application" error when starting a simulation or viewing simulation
results, but you see PSpice or Probe start, try the following:
In the [SCHEMATICS] section of the MSIM.INI file, add the following line:
WaitForApp = 30
This is the number of nanoseconds that Schematics will wait if it is not able to detect that the
simulator or another MicroSim program has started. The default is 20 nanoseconds. Typically,
no wait is needed, but on some systems it is helpful.


Unexpected word wrapping when editing textboxes
At certain zoom levels, depending on the font, text may unexpectedly wrap
when you click to edit the text. This occurs when the enclosing textbox's width is
extremely close to the end of the longest line. For single-line text, this wrapping will
cause all but the last word to disappear.
To correct this, make the enclosing textbox wider by dragging one of its handles.


Repainting problem with dialogs overlapping inserted bitmaps (Insert Picture)
Windows 95: Inserting color bitmaps on a schematic can cause repaint problems for
dialog boxes (such as File Open and Print) and other open windows on your desktop.
This problem typically occurs with 16 color bitmaps with a palette.
If you do not have the latest device drivers for your video card, try converting your bitmap to a
256 color or true-color bitmap using a graphics editor (such as Microsoft (R) Paint) to correct the
problem.

PCBoards


Incorrect file names in post-processing log files
In the post-processing log files, the file names <filename>.dlg and <filename>.glg listed in the
photoplot and drill files are incorrect. Ignore the extra ".dlg" or ".glg" in the full file name.
The files are correct, but the log file report names them incorrectly.
For example:
c:\Projects\<filename>.glg.g01 (incorrect)
c:\Projects\<filename>.g01 (correct)


Tools/CCT: Edit Do File
If the layout file name is not in DOS style 8.3 format (that is, if the name has spaces in it), the
menu command will not start the text editor and open the .do file. The .do file will still be sent to
SPECCTRA and will be processed as usual. To edit it, start a text editor and look for a name
with (normally) the first six letters of your layout file name, followed by ~1.do.

PSpice A/D & Basics+


In the libraries provided with your applications, there are a number of parts that use
delay line models that are not supported by the simulation. The use of these models
may produce erroneous simulation results. The names of these parts and their
libraries are as follows:
•
•
•
•
•

74121, 74122, 74123 in 7400.lib
CD4098B, CD4538B in CD4000.lib
74LS122,74LS123 in 74LS.lib
54L121, 54L122, 54L123 in 74L.lib
555D (Mixed A/D model for the CMOS version of the 555 Timer) in dig_misc.lib.

In addition, the Subckt DELAY (a generic delay line model in dig_misc.lib) is also not
supported by the Basics+ package.

Libraries


The following are all-new libraries created for this release:
maxim
phil_rf
phil_fet

phil_bjt
siemens
zetex

The following libraries have new and/or updated models:
anlg_dev
ediode
igbt
nat_semi

burr_brn
elantec
jpwrjbt
opamps

diode
harris
motor_rf
polyfet

Tech Tips


Q
A

"I get a blue screen in MicroSim Schematics when I run it, and I can't place any parts."
The evaluation software should be run from the MicroSim Program group on the Start
menu, rather than from the Run command. The evaluation programs use a differently
named msim.ini configuration file, which needs to be specified as part of the Shortcut. This
command line specification of the msim_evl.ini file is built into the icons in the MicroSim
Program group on the Start menu. An example shortcut target line (for MicroSim
Schematics) is:
C:\MsimEval_8\PSCHED.EXE -i msim_evl.ini

Q
A

"Can I run Release 8 under Windows 3.1/3.11?"
No. Release 8 will not run under Windows 3.1/3.11. Release 8 will run under Windows 95
or Windows NT.

Q
A

"Why is the installation taking so long?"
Some screen saver programs (when loaded and running in the background) can slow down
the installation program by as much as a factor of 3. To improve the performance of the
installation, disable your screen saver for the duration of the installation.

Q

"Should I let the installation program update my Registry?"

A

If you update the Registry, you can start a MicroSim program automatically by doubleclicking a file of a registered type. For example, you can double-click an .sch file and start
Release 8 MicroSim Schematics by opening that file. Similarly, you can double-click on an
.lib file to start Release 8 MicroSim Parts.

Q
A

"Why is Acrobat Reader saying it can't find this file?"
If you performed a Typical installation, the online manuals were not installed on your local
hard drive. When you access an online manual, Acrobat Reader looks for the file on the
MicroSim CD-ROM, and when it's not in your CD-ROM drive, you get a message that it
can't find the file. To install the online manuals on your computer, select Custom
installation.

Q
A

"Can I get extra copies of the manuals?"
You will find online copies of our manuals in a number of places: on your MicroSim CDROM, on the evaluation version CD-ROM, and most recently, it is accessible on our Web
site (available for downloading).

Q
A

"How do I specify trace colors in Probe using Markers in Schematics?"
Do one of the following:
On the Simulation Toolbar, click the Select Marker Color button, then select a color, and
place a marker.
Select a marker, then click the Select Marker Color button, and select its color.
Using different colors for each marker makes it easy to identify traces in Probe. If you do
not specify trace colors in this way, Probe will automatically assign unique colors to each
trace as it is drawn until all of the available colors are used once. After each color has been
used once, Probe uses them again, but adds symbols to each trace (which are correlated
to the trace variables in the legend of the plot window) to keep the traces unique.
If you mix methods (that is, specify some colors explicitly and let Probe select others), you
may reach a point where two traces have the same color (and use of symbols). To correct
this, from the Tools menu, select Options, and in the Use Symbols frame, select Always.

Documentation Errata
Schematics User's Guide


p. 3-41: In the section "Changing the Get Recent Part List Size," the second paragraph should
read as follows:
To change the length of the list, use a text editor to edit the MAXMRPLISTSIZE item in the
[SCHEMATICS MRP LIST] section of the msim.ini file.
MAXMRPLISTSIZE=<length of list>


In the schematic editor, the Snap-to-Grid option is no longer available from the Display Options
dialog box under the Options menu. Enabling Stay-On-Grid (which is enabled by default) will
force items to stay on grid.


In the symbol editor and schematic editor, there is now a Restore All Defaults button on the
Display Preferences dialog box under the Options menu. This button restores the originally
installed values for all layers.

Given the complexity of present-day integrated circuits, circuit designers need to have a greater breadth of knowledge than ever before.
This text is intended to provide an introduction to this important and rapidly changing discipline. Many engineers who will never design
an electronic circuit need to have a basic understanding of the characteristics of electronic circuits because they fabricate, test, or use
these circuits, or they design systems that eventually have to be implemented using these circuits.Â There is more than enough
material in this text for a two semester or three quarter sequence in electronic circuit design. Several different instructors have used
drafts of this text for a two-quarter sequence at the University of California at Davis for several years. A basic understanding of circuit
design is useful for many engineerseven those who may never actually design a circuitbecause it is likely that they will fabricate, test, or
use these circuits in some way during their careers. This book provides a thorough and rigorous explanation of circuit design with a
focus on the underlying principlesof how different circuits workinstead of relying completely on design procedures or "rules of thumb." In
this way, readers develop the intuitionthat is essential to understanding and solving design problems in those instances where no
procedure exis...Â Devotes a whole chapter to device physics.For reference use by professionals in the field of computer engineering or
electronic circuit design. In this project you will use AutoCAD Electrical to design electrical circuits.Â You will also get an introduction to
using schematic information to select the physical footprints of components for defining a control panel layout to make sure your control
panel can accommodate the components needed. Go further into 3D and electromechanical design. Electrical and electronic
components can be found in every product. This project gives you a foundation that can applied in other projects requiring electrical or
electronic components, control systems and others. Electrical circuits could and should be used further to design electromechanical
assemblies in 3D. Download the lesso

